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I n du c t o r  i n  Amp l i f i e r  C i r c u i t

This model studies a finite element inductor inserted in an electrical amplifier circuit.

Introduction

Modern electronic systems are very complex and depend heavily on computer aided 
design in the development and manufacturing process. Common tools for such 
calculations are based on the SPICE format originally developed at Berkeley University 
(Ref. 1). The SPICE format consists of a standardized set of models for describing 
electrical devices—especially semiconductor devices such as transistors, diodes, and 
thyristors. SPICE also includes a simple, easy-to-read text format for circuit netlists and 
model parameter specifications. Although the netlist format is essentially the same as it 
was from the beginning, the set of models and model parameters are constantly 
changing, with new models being added according to the latest achievements in 
semiconductor device development. When the devices are scaled down, new effects 
appear that have to be properly modeled. The new models are the result of ongoing 
research in device modeling.

When an engineer is designing a new electronic component, like a capacitor or an 
inductor, the SPICE parameters for that device are not known. They are either 
extracted from finite element tools, such as COMSOL Multiphysics, or from 
measurements on a prototype. To speed up the design process it can be convenient to 
include the finite element model in the SPICE circuit simulation, calculating the device 
behavior in an actual circuit.

This model takes a simple amplifier circuit and exchanges one of its components with 
a finite element model of an inductor with a magnetic core. COMSOL Multiphysics 
calculates the transient behavior of the entire system. A script adds the circuit elements 
as ODE equations to the inductor model along with the necessary model parameters 
for the SPICE devices in the circuit.

Model Definition

The inductor model uses the Azimuthal induction currents application mode of the 
Electromagnetics module, solving for the magnetic potential A.

σ A∂
t∂

------- ∇ µ0
1– µr

1– ∇ A×( )×+ Je=
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where µ0 is the permeability of vacuum, µr the relative permeability, and σ the electrical 
conductivity.

Because the inductor has a large number of turns it is not efficient to model each turn 
as a separate wire. Instead the entire coil is treated as a block with a constant external 
current density corresponding to the current in each wire. The conductivity in this 
block is zero to avoid eddy currents, which is motivated with the fact that no currents 
can flow between the individual wires. The eddy currents within each wire is neglected.

C O N N E C T I O N  T O  A  S P I C E  C I R C U I T

The electrical circuit is a standard amplifier circuit with one bipolar transistor, biasing 
resistors, input filter, and output filter, see the figure below.

The input is a sine signal of 1 V and 10 kHz. The SPICE netlist for this circuit is shown 
below.

* BJT Amplifier circuit
.OPTIONS TNOM=27
.TEMP 27
Vin    1    0    sin(0 1 10kHz)
Vcc    4    0    15
Rg     1    2    100
Cin    2    3    10u
R1     4    3    47k
R2     3    0    10k
X1     4    5    inductor
RE     7    0    1k
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Cout   5    6    10u
Rl     6    0    10k
Q1     5    3    7    BJT
.MODEL BJT  NPN(Is=15f Ise=15f Isc=0 Bf=260 Br=6.1 
+ Ikf=.3 Xtb=1.5 Ne=1.3 Nc=2 Rc=1  Rb=10 Eg=1.11  
+ Cjc=7.5p Mjc=.35 Vjc=.75 Fc=.5 Cje=20p Mje=0.4 Vje=0.75
+ Vaf=75 Xtf=3 Xti=3)
.SUBCKT inductor V_coil I_coil COMSOL: amplifier_and_inductor.mph
.ENDS
.END

The device X1 refers to a subcircuit defined at the end of the file. The subcircuit 
definition is part of the SPICE standard to define blocks of circuits that can be reused 
in the main circuit. The special implementation used here defines a subcircuit that 
really is a Comsol Multiphysics file, referenced with the option 
COMSOL: <file name>. The parameters V_coil and I_coil are the variables that 
links the model file with the circuits. These variables must be defined in the model in 
a certain way. The variable V_coil must give the voltage over the device, defined in 
the global scope. I_coil must be a global variable used in the model as a current 
through the device.

The script can also handle model files with more than two terminals. It is then 
necessary to define each terminal as a floating-potential boundary condition. Note that 
any use of the ground boundary condition will connect those boundaries directly to 
the ground node of the circuit, labeled 0.

The model parameters of the transistor do not correspond to a real device, but the 
numbers are nevertheless chosen so as to be realistic.

The script to import the SPICE netlist is called spiceimport.m. This script does not 
fully support the SPICE format; especially for the semiconductor device models, it 
only supports a limited set of parameters. Supplying unsupported parameters does not 
give an error message, but the parameter is not used in the circuit model. For example, 
the transit time capacitance and the temperature dependence are not supported for the 
transistor model.

Results and Discussion

Biasing of an amplifier is often a complicated compromise, especially if you only use 
resistors. Adding an inductor as the collector impedance simplifies the biasing design, 
since the instantaneous voltage on the collector of the transistor can be higher than the 
supply voltage, which is not possible with resistors. Amplifiers using inductors can be 
quite narrow banded.
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Before starting the transient simulation, proper initial conditions have to be calculated. 
For this model it is sufficient to ramp the supply voltage to 15 V with the nonlinear 
parametric solver. After the ramp, the DC bias conditions have been calculated 
properly and this solution can be used as initial condition for the transient simulation. 
After 0.2 ms the magnetic field and contour lines of the vector potential should look 
like Figure 1 below.

Figure 1: Magnetic flux density (color) after the bias point calculation.
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Using the global variable plot, input signal, output signal, and inductor voltage can 
easily be plotted in the same graph.

Figure 2: Input signal (U_VIN_cir), output signal (U_RL_cir), and inductor voltage 
(U_X1_cir) as a function of time.

The output signal is about 1.5 times the input signal in amplitude.

Reference

1. “The SPICE home page,” http://bwrc.eecs.berkeley.edu/Classes/IcBook/
SPICE.

Model Library path:  

AC/DC_Module/Electrical_Components/amplifier_and_inductor
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Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 In the Model Navigator, choose Axial symmetry (2D) in the Space dimension list.

2 In the AC/DC Module folder, select Statics>Magnetostatics>Azimuthal Induction 

Currents, Vector Potential.

3 Click OK to close the Model Navigator.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

1 In the Constants dialog box, define the following constants with names and 
expressions. The description field is optional.

2 Click OK.

3 From the Options menu, choose Expressions>Global Expressions.

4 In the Global Expressions dialog box, define the following variables with names and 
expressions. The description field is optional.

5 Click OK.

G E O M E T R Y  M O D E L I N G

1 Choose Draw>Specify Objects>Circle to create a circle with the following properties:

NAME EXPRESSION DESCRIPTION

t 0 Time for stationary solution (s)

N 1e3 Turns in coil

freq 10e3[Hz] Frequency

r_coil 0.05e-3[m] Wire radius in coil

sigma_coil 5e7[S/m] Wire conductivity

NAME EXPRESSION DESCRIPTION

I_coil 1[A] Current in coil

J_coil I_coil*N/A Equivalent current density in coil

NAME RADIUS BASE R Z

C1 0.03 Center 0 0
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2 Choose Draw>Specify Objects>Rectangle to create rectangles with the following 
properties:

3 Click the Zoom Extents toolbar button to see the objects.

4 Select the circle and the third rectangle (C1 and R3), and click the Intersection 
toolbar button.

5 Open the Fillet/Chamfer dialog box from the Draw menu.

6 In the dialog box, expand rectangle R1 and select Vertices 2 and 3. Then expand 
rectangle R2 and select all vertices there. Hold down the Ctrl key to do multiple 
selections.

7 In the Radius edit field type 5e-4.

8 Click OK.

P H Y S I C S  S E T T I N G S

Variables
1 From the Options menu, point to Integration Coupling Variables and click Subdomain 

Variables.

2 In the Subdomain Integration Variables dialog box, define two variables with 
integration order 4 and global destination according to the table below.

3 Click OK.

Subdomain Settings
1 Open the Subdomain Settings from the Physics menu.

2 Select Subdomain 2 and click the Load button to open the Materials/Coefficients 

Library dialog box.

3 In the dialog box, select the Soft Iron material under the acdc_lib.txt library. (You 
may have to scroll both vertically and horizontally to see the library name.)

NAME WIDTH HEIGHT BASE R Z

R1 5e-3 2e-2 Corner 0 -1e-2

R2 3e-3 2e-2 Corner 7.5e-3 -1e-2

R3 0.04 0.08 Corner 0 -0.04

NAME EXPRESSION IN SUBDOMAIN 3

V_coil N*2*pi*r*I_coil/(sigma_coil*pi*r_coil^2)

A 1
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4 Click OK to close the Materials/Coefficients Library dialog box.

5 Select Subdomain 3 and enter J_coil in the External current density edit field.

6 Click the Init tab, select all subdomains, and type 1 in the edit field for the initial 
value.

7 Click OK.

Boundary Settings
1 Open the Boundary Settings from the Physics menu.

2 Select Boundaries 1, 2, and 4, then choose Axial symmetry from the 
Boundary condition list. For all other boundaries keep the default condition, 
Magnetic insulation.

3 Click OK.

M E S H  G E N E R A T I O N

1 Open the Free Mesh Parameters dialog box from the Mesh menu.

2 Click the Custom mesh size option button and type 4 in the Resolution of narrow 

regions edit field.

3 Click Remesh and then OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solve button.

2 From the File menu, choose Save As. Save the model to the file name 
amplifier_and_inductor_nocircuit.mph. It is important that this file name is 
the same as the file name specified in the circuit file. Also remember the location 
where you save the file.

This completes the first part of the model, which is to create the model file of the 
inductor that is connected to the circuit file later.

S P I C E  I M P O R T

These steps require that you have access to COMSOL Script or MATLAB. If you use 
MATLAB, COMSOL Multiphysics must be opened with MATLAB.

1 First create the circuit file in an editor of your choice. Create the text content as it 
is shown below.

* BJT Amplifier circuit
.OPTIONS TNOM=27
.TEMP 27
Vin    1    0    sin(0 1 10kHz)
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Vcc    4    0    15
Rg     1    2    100
Cin    2    3    10u
R1     4    3    47k
R2     3    0    10k
X1     4    5    inductor
RE     7    0    1k
Cout   5    6    10u
Rl     6    0    10k
Q1     5    3    7    BJT
.MODEL BJT  NPN(Is=15f Ise=15f Isc=0 Bf=260 Br=6.1 
+ Ikf=.3 Xtb=1.5 Ne=1.3 Nc=2 Rc=1  Rb=10 Eg=1.11  
+ Cjc=7.5p Mjc=.35 Vjc=.75 Fc=.5 Cje=20p Mje=0.4 Vje=0.75
+ Vaf=75 Xtf=3 Xti=3)
.SUBCKT inductor V_coil I_coil ...1

COMSOL: amplifier_and_inductor_nocircuit.mph
.ENDS
.END

2 Save the file as amplifier.cir in the same location as the model file you saved 
earlier. Then go back to the COMSOL Multiphysics window.

3 Go to the COMSOL Script window. You open the window with the File>COMSOL Script 

menu item.

4 At the command prompt, first make sure that you are in the correct folder where 
the model file and circuit file are stored, then enter the following command.

fem = spiceimport('amplifier.cir');

5 Go back to the COMSOL Multiphysics window and choose Import>FEM structure from 
the File menu. Type fem in the dialog box that appears and click OK. 

The model is the same as before but with constants, global variables, and ODE 
variables added that represent the amplifier circuit. The syntax of these variables are 
related to the names in the file. The variable I_R1_cir stands for the current in resistor 
R1, value_VCC_cir is the voltage value of the supply voltage generator VCC, and 
U_X1_cir is the voltage over the device X1, which is the inductor model you created 
earlier. The variables beginning with the letter V are node potentials referenced to the 
ground node, 0, of the circuit.

C O M P U T I N G  T H E  S O L U T I O N  W I T H  A  C I R C U I T

1 Open Solver Parameters from the Solve menu.

2 In the Solver Parameters dialog box, select Parametric from the Solver list.

1. ‘...’ Indicates that the line break should be omitted in the amplifier.cir file. I.e. “.SUBCKT 
inductor V_coil I_coil COMSOL: 
amplifier_and_inductor_nocircuit.mph” must appear on one line.
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3 In the Name of parameter edit field type value_VCC_cir, and in the List of 

parameter values edit field type 1:15.

4 Click OK.

5 Click the Restart button. 

This solving step ramps the supply voltage stored in value_VCC_cir up to 15 V. The 
ramp is necessary to handle the highly nonlinear effects in the bipolar transistor model. 
The circuit is now at its bias point, and the plot should look like Figure 1 on page 4.

1 From the Options menu point to Integration Coupling Variables and click Subdomain 

Variables.

2 In the Subdomain Integration Variables dialog box change the expression for the 
V_coil variable so it matches the expression below.

3 Click OK.

4 Open Solver Parameters from the Solve menu.

5 In the Solver Parameters dialog box select Transient from the Analysis list.

6 Type linspace(0,5e-4,101) in the Times edit field, type 1e-4 in the Relative 

tolerance edit field, and type 1e-6 in the Absolute tolerance edit field. The last steps 
are because the accuracy obtained with default error tolerances is not sufficient in 
this model.

7 Click OK.

8 Click the Restart toolbar button.

NAME EXPRESSION IN SUBDOMAIN 3

V_coil N*2*pi*r*I_coil/(sigma_coil*pi*r_coil^2-Ephi_emqa/A)
I N D U C T O R  I N  A M P L I F I E R  C I R C U I T  |  10



amplifier_and_inductor.book  Page 11  Monday, August 28, 2006  2:53 PM
PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

1 Open Global Variables Plot from the Postprocessing menu.

2 From the Predefined quantities list select the variables U_X1_cir, U_VIN_cir, and 
U_RL_cir. Click the > button to add the selected variables to the Quantities to plot list.

3 From the Solutions to use list, select all the time steps from 4e-4 to 5e-4.

4 Click the Line settings button. In the dialog box that appears, select Cycle from the 
Line marker list, and select the Legend check box. Click OK.

5 Click OK to see the plot in Figure 2 on page 5.
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